LongTail Video is now JW Player - New Name, Same Passion For Video

Close

Open Video Ads Forums

CATEGORY:

/

Task Queue failed at step 0: Error #2032

12 replies [Last post]

A lot of users are reporting to see the error:
"Task Queue failed at step 0: Error #2032"
This doesn't happen with all people and the error appeares almost from the OVA plugin installation day.

Some reporters send us his browser user-agent and flash player's version, they have firefox (3.63 and 4), chrome and IE9 on Windows platform and the last version of flash.
I have Chrome and the last version of flash but I don't see this error.

The website is www.youreporter.it and an example page with OVA is:
http://www.youreporter.it/video_Gatto_gioca_con_l_iPad_1

This is an example page without OVA, the users that see the error reports to don't see the error here:
http://www.youreporter.it/video_23_11_08_ORE_21_30_A_PCIML-TV_DRAMMA_DEI_DISABILI

Thanks,
Alessandro

Hi Alessandro,

I've been trying to reproduce this with your URL but haven't been able too.. think the first thing for me to track down the problem is to reproduce it.

Can I ask a few more questions to try to pinpoint it:

1. Are the users only reporting the issue under Windows?

2. Does that error message appear when the player loads or after the ad plays?

3. Have you been able to reproduce it at all yourself?

I'll keep trying and investigating but any further information you can provide will help....

Paul

Just another thought, but apparently Error #2032 is a general Flash "file not found" error...

I'm wondering if the users that are experiencing the problem have Adblock Plus installed? That may cause this type of issue...

?

Paul

Looking more into it, it definitely seems to be related to a "file not found" type issue.

Here's a good posting on the source of the error code:

http://www.judahfrangipane.com/blog/2007/02/15/error-2032-stream-error/

Alessandro - one more thing I'm wondering - do all users get the same ads etc. when they load up the page:

http://www.youreporter.it/video_Gatto_gioca_con_l_iPad_1

I'm wondering if I see the same output that everyone experiencing the problem sees?

What would be good is if you could get a cut and paste of the OVA debug info from the Chrome developer tools console when a user sees the error - that may help pinpoint where the "file not found" error is occurring?

Any chance you could get a debug dump and email it over to me at enquiries@openvideoads.org?

Paul

Hi Alessandro.. one more important pointer...

"Step 0" in that error message points to an issue loading up the config xml file.

Looking at your setup, you are loading a config file:

'config': "http://www.youreporter.it/adv/ova-matrix.xml.php?bust=" + bust,

So my guess is now that your users aren't successfully getting that config file off your servers when they see the error.

A couple of thoughts:

1. A server in your rotation is having a problem and not serving the file
2. The server is getting overloaded and not able to serve the file
3. The file is missing in one of your servers (if you have multiple in rotation)

etc.

Paul

Hi Alessandro,

I was thinking more about this overnight.

One thing you could do to remove this problem is switch to JW5.6 and the latest OVA developer build and embed your OVA configuration in the JWEmbedder player setup code - this will remove the need to load the external configuration file and should make the problem go away...

Paul

Paul thanks for your replies.

I answer your questions:
1. The users reporting problems use Windows
2. The message appeares before the ad. Both ad and video don't work
3. I can reproduce using AdBlock Plus and Italian Filters Subscription (but the users reports to don't use AdBlock)
4. We have only one node delivering the config file

I found that the config file is blocked because is in the /adv/ folder. Move it to another folder solves the problem.

I will ask to the users who says to not use AdBlock if this fix works for theme. I think some geek installed AdBlock on these computers and they don't know that. I will write you some news about this issue.

Thanks Paul Schulz! It was adblock plus, I allowed the site and the video works great..

I created one playlist which worked fine, then took the HTML code and copied to a new page for another playlist. I'm working in MS FrontPage 2000 on WinVista Home Premium.

When I try to Preview the 2nd playlist I get this error message:
"Task Que failed at Step 5: Playlist could not be loaded. |Error #2032."

I also get a script error that says: "object expected at line 24 character 5 Error Object expected Code 0"

This is the script code:
<html>
<head>
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js" </script>
<script type="text/javascript" src="/jwplayer/jwplayer.js"></script>
<title>JWPlayer test</title>
</head>

<body>
<p align="center"><font face="Arial" size="4"><b>JWPlayer Code Example-tommie
rose<br>
</b></font><font face="Arial">error - object expected in line 24 character 5<br>
can't find anything wrong there</font><hr>
<div id="container">Loading the player...</div>

<script type="text/javascript">
jwplayer("container").setup({
flashplayer: "/jwplayer/player.swf",
playlist: [
{ file: "Lord, Your Will Not Mine - Carol Jean White, tommie rose.flv" },
{ file: "Soul Fire.flv" },
{ file: "The Heart of Love.flv" },
{ file: "The Printer's Song - tommie rose.flv" },
{ file: "Soul Fire - short version.flv" },
{ file: "Thunder of the Drums.flv" }
],
"playlist.position": "right",
"playlist.size": 360,
height: 270,
width: 720
});
</script>

Line 24 (on the whole page of HTML code says:
"playlist.size": 360,

All files (.htm file, jwplayer.js, swfobject.js, player.swf and all .flv files) are in the same folder. There is also a "sample.xml" which is not used but which I put there as a guide if I needed it.

When I try to view it in FF 4.01 it says "Player loading ..." but it never does.

In IE 7 there is just a black box - nothing happens with it. I'm not using any plugins or particular skins. I took the code directly from the JWPlayer site.

HELP!!

@Jim - Please provide a link to where this is happening. Also, what does this have to do with OVA?

Fresh Drupal 6 install from http://drupal.org/project/jwplayermodule . Get the same error. Apparently 2302 is the Flash code for a missing file. View source. Which file is missing?

<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, { "jwplayer": { "files": { "jwplayer-1": { "flashplayer": "http://{myurl}/sites/default/files/jwplayermodule/player/player.swf", "width": "400", "height": "280", "controlbar": "bottom", "wmode": "opaque", "file": false, "image": false, "config": "http://{myurl}/sites/default/files/jwplayermodule/configs/Out-of-the-Box.xml", "events": [  ] }, "jwplayer-2": { "flashplayer": "http://{myurl}/sites/default/files/jwplayermodule/player/player.swf", "width": "400", "height": "280", "controlbar": "bottom", "wmode": "opaque", "playlist": [ { "file": "http://{myurl}/sites/default/files/verbal_final_0.mp3" } ], "config": "http://{myurl}/sites/default/files/jwplayermodule/configs/Out-of-the-Box.xml", "events": [  ] } } } });
//--><!]]>
</script>

http://{myurl}/sites/default/files/jwplayermodule/configs/Out-of-the-Box.xml is missing. The only file in that directory, with a fresh default install, is sample.xml.

Change name of file from sample.xml to Out-of-the-Box.xml and all is light. Fwiw, you guys will either want to 1) rename the file in your distro, or 2) change the code which generates the above to instead reference sample.xml .

If I have failed to find this in the FAQ, I apologize.

Glad you got it working.

Still don't have the new JW Player? Get It Here