LongTail Video is now JW Player - New Name, Same Passion For Video

Close

JW Player Forums

CATEGORY:

/

JWPlayer crashing in Google Chrome only

17 replies [Last post]

Since Friday evening, our JWPlayer implementation has been crashing on Google Chrome only. IE, FF, and Safari test fine. Anyone else experiencing this?

What happens is the video player loads just fine, and if the video is set to autostart that works just fine. But as soon as you interact with the player by clicking anywhere inside the player frame, it crashes the page.

After extensive testing, it appears that videos embedded using the older Embed/Object methods work without crashing. But videos embedded using the newer JS methods (JW Embedder, SWFobject) are unstable and crash frequently (it doesn't happen 100% of the time, but almost all the time).

The crashing has been tested and confirmed on three different machines running Chrome. Prior to Friday, all videos were playing without issue in Chrome. So I'm wondering if there was some kind of Flash/Chrome update causing stuff to choke, but that might be a wild guess.

We've reinstalled the swf files and swfObject/JWPlayer JS files onto our servers, and made sure the JS files are properly linked to the pages. Hasn't seemed to help.

Any ideas?

This is a development environment so I hesitate to post a link unless absolutely necessary...

I test my pages using IE, FF, Opera, Safari, Google Chrome, Maxthon and it works very well.

May I suggest that you use a different method for the JWPlayer than using the swfobject.js? I differ with the use of swfobject for several reason but mainly that it adds unnecessarily an http call which is what one wants to keep at the very minimum when considering web optimization.

My multimedia section on my web site uses the JWPlayer exclusively for both audio and video.

I place the following code just above the closing html closing body element ( </body> ). Try it as an alternative method

               <!-- JavaScript -->
    <script src="js/jwplayer.js"></script>   
    <script>
          //<![CDATA[
var options =
             {
                image:'contents/rat.jpg',
file: 'contents/ratatouille.flv',
                width:'800',
                height:'340',
                bufferlength:'1',
                controlbar:'none',
                stretching:'fill',
                fullscreen:'true',
                autostart:'false',
                players: [{ type: "flash", src: "player.swf" }]

};

function embedPlayer(id) {
$jw(id).setup(options).onPlay();
                jwplayer("id").remove();
}

           //]]>
</script>
    <script>
            embedPlayer('div1');
    </script>

Then somewhere in my html code i use the following.

<article id="div1"></article>

The above works great in all of the browser types that I test with.

@rah - We will need a link to be able to debug/replicate this.

I have the same ploblem with Google Chrome: clicking on the frame of the video, it crash.

Instead, if I click an image that executes "javascript:jwplayer().play();" the video starts correctly.

The player is called with:

<script type="text/javascript">

jwplayer("container").setup({
flashplayer: "../flvlib/player.swf",
controlbar: "none",
'plugins': {
'sharing-2': {
}
},
file: "../files/av0071_01_H264.m4v",
width: 528,
height: 432,
'modes': [
{type: 'html5'},
{type: 'flash', src: '../flvlib/player.swf'},
{type: 'download'}
]
});

</script>

@Luca

Link please

http://dev2.dyndevicelcms.com/

You must do login:

Username: lsigalini
Password: lsigalini
Click -> LOGIN

Go to page:
Fruizione corsi (first link in top left)

Select the course:
OTTOUNO - D. Lgs. 81/2008 (Versione Uffici) (DEMO)

Select the chapter:
Introduzione

@Luca

Grazie per aver postato un link.
Io ho guardato e forse offrire qualche informazione SE non la soluzione si vogliono.
Io contiue inglese, come io non arrivare a usare il mio Piero Arpino molto spesso

I believe you are referring to an 'iframe', correct?

You indicate above frame and thus I am assuming it is an iframe you are referring to.

Chrome is a strange creature when it comes to an iframe. Of all the browsers that I test my web site with, it was Chrome that gave me the biggest headache.

Initially the iframe worked in all browsers BUT not in chrome. After spending considerable time and many cups of espresso coffee only to find that I had to change from 'position:absolute' to 'position:relative'.

After changing it to position:relative, the iframe worked in all of the browsers that I used in testing.

Here is a tip(free of charge ;-) as I noticed in looking at your code you have the following

<meta http-equiv="X-UA-Compatible" content="IE=8" />

May I suggest that you use the following:

<meta name="X-UA-Compatible" content="IE=edge,chrome=1, env=ie">

This sets the X-UA-Compatible mode to use the latest browser compatibility of IE-Edge or Chrome.

OR
You can set this in your .htaccess file
and also the following in my .htaccess file so that the pages validate in these IE browsers:


<IfModule mod_setenvif.c>
  <IfModule mod_headers.c>
    BrowserMatch MSIE ie
    Header set X-UA-Compatible "IE=Edge,chrome=1" env=ie
  </IfModule>
</IfModule>

That said, I am not sure if the absolute/relative position will solve your issue/problem BUT it is worth checking out in any case.

Se desiderate non esitate a visitare il mio sito web e sono sicuro che troverete non solo la mia galleria fotografica delle Montagne canadese Rockey ma anche la sezione multimediale particolarmente la sezione video.

www.mirana.net

Hanno un grande giorno

Thank's Willie!

Indeed, the problem is due to the iframe because if calling directly:

http://dev2.dyndevicelcms.com/_resources/scorm/MIM_LO_0001_DEMO/resources/lo_0001_02.htm

the crash does not occur!

I tried to insert:

<meta name="X-UA-Compatible" content="IE=edge,chrome=1, env=ie">

in the main document and add to the <iframe>
style="position: relative;"

but the problem remains...

However, knowing that the crash is caused by the frame, it will help me a lot.

Thank you very much!

Grazie

Your welcome

I'm consistently seeing crashes on Google chrome.

link is http://gsmtesting.co.nz/ajax/getProCamById2.php?regionId=PH&resId=2

Any ideas what's causing this? It seems the longer the clip plays the less likely it is to crash.

What version of Chrome? What OS?

Chrome latest : 21.0.1180.89
PPapi : Pepper flash player 11.3.31.232

I have the same version of Chrome / Flash, can't replicate anything on that link. Is this even your site?

Sry my bad English.

Streamcloud use JwPlayer

The Videos stutters

Link :

http://onlinewebfilmek.blogspot.com/2012/08/star-trek-az-uj-nemzedek-1-7evad-online.html

A direct link :

http://streamcloud.eu/b2wez9nwozr0/S.T.Az___j_n._-_1x03.A_t__boly.avi.html

Wait and click Weiter Zum Video button

I don't notice any noticeable stuttering here.

Thank you for your answers.

Np

Still don't have the new JW Player? Get It Here