LongTail Video is now JW Player - New Name, Same Passion For Video

Close

JW Player Forums

CATEGORY:

/

Video delay on livestream with Wowza 3

9 replies [Last post]

Hi.
I have a Wowza 3.0.3 installation and available livestream application
on my Linux box. When I playing stream with Wowza sample player there is no delay on video, but whet I try to play the same stream with JW Player 5 there is a delay at least 5 seconds.

Player code:

jwplayer("container").setup({
        file: "live",
        height: 240,
        width: 320,
        bufferlength: 1,
        'provider':'rtmp',
        'streamer':'rtmp://media.TESTING.info:1935/videochat',
        'modes': [
                {
                        type:'flash',
                        src:'player.swf',
                        'config': {
                                'file': 'live',
                                'streamer': 'rtmp://media.TESTING.info:1935/videochat',
                                'provider': 'rtmp'
                        }
                },
                {
                        type:'html5',
                        config:{
                                'file':'http://media.TESTING.info:1935/vod/mp4:live/playlist.m3u8',
                                'provider':'http'
                                }
                }
        ]
});

I played around bufferlength (tried to set 0.2, 0.5, 1, 2) but with no luck. Delay on video picture is always not less than 5 seconds.

Could you suggest how can a lower delaying can be achieved?

We'd have to add a fix to the player to lower the bufferlength by default. This will work with the 5.7 player, but not with 5.8 (where the length is automatically set).

Hi
we have the same problem (delay always above 5 sec)
also when using jwplayer 5.7 and 5.8

<script type="text/javascript">

jwplayer("one").setup({

height: 270,
width: 480,
bufferlength: 1 ,
modes: [

//first choice
{ type: "flash",
src: "jwplayer57/player.swf" ,
config:
{
file: "camera.stream" ,
streamer: "rtmp://192.168.1.10:1935/live",
provider: "rtmp",
autostart: 'true'
}
},
....
]
});
</script>

pleas advise
Thanks

We're looking into this

I'm also seeing this in flash going through Wowza. Testing locally I see a delay of 3 seconds.

jwplayer("screenViewerDIV").setup({
"autostart": true,
"bufferlength": 0,
"smoothing": false,
"stretching": "none",
"events": {
onError: function(event) {
console.log("got error");
console.log(event);
display_error(event.message);
stop_viewing();
},
onReady: viewing_started,
onMeta: process_video_metadata,
onBufferFull: function() { console.log("got onBufferFull event") },
onBufferChange: function() { console.log("got onBufferChange event") },
onBuffer: function() { console.log("got onBuffer event") }
},
"modes": [
{
"type": "flash",
"src": "jwplayer/player.swf",
"config": {
"provider": "rtmp",
"file": "603f9660-6f12-11e1-9dda-45542ef0f457",
"streamer": "rtmp://localhost:1935/live"
}
},
{
"type": "html5",
"config": {
"file": "http://localhost:1935/live/mp4:603f9660-6f12-11e1-9dda-45542ef0f457_360p/playlist.m3u8",
"provider": "video"
}
}
]
});

How is this bug correction going??

I'm still having a big delay on second with rtmp playing.
Any idea??

I have 5.9 JwPlayer installed

Same issue here.

The problem is: 5.7 and lower now have a huge problem with Flash 11.2 - so we can only use 5.8 or 5.9 ... but there is a too huge delay.

Any news on this?

With Strobe Player I have about 2 secs delay.
http://www.osmf.org/dev/2.0gm/setup.html

We are working on this for the next player update. The default bufferlength will still be a few seconds, but you'll be able to set it to something low (like 0.1) for your streams.

The work goes into ensuring adaptive streaming heuristics don't break when setting low buffer values. They swiftly become very unstable then.

Good to know!
Thanks for the info!

Still don't have the new JW Player? Get It Here