LongTail Video is now JW Player - New Name, Same Passion For Video

Close

JW Player Forums

CATEGORY:

/

video not found or access denied

34 replies [Last post]

http://dev.stratpoint.com:8114/mediaplayer/

please review the page on that URL, i have reviewed the filename of the video and it is on the same directory but i cant seem to run it when im accessing it from the outside, but locally on the server the video plays.

also, please verify if my implementation of the google analytics plugin is correct..

i will gladly appreciate your immediate reply. :)

oh, it doesn't play locally because of the google analytics plugin settings..

help please...

thanks...

Your files does not load - http://dev.stratpoint.com:8114/mediaplayer/thisisme.flv, it is not there. That is the issue.

the file, thisisme.flv, is in the same directory with the webpage.
if that is the problem, then how should i specify the file in the page?

hi, the bug was resolved by configuring the mime types...

http://it.toolbox.com/blogs/rymoore/adding-flv-mime-type-in-iis-4198

Ah, great, thanks for letting me know! :)

Got exact same errors.....then I discovered the file is Case Sensitive.....

I had the file in small letters in the code,,but..... I had the name of the file in capital letters so it didn't recognize it..//// I just accidentally figured this out/////

And now it works....since I changed everything to small letters....

example...... " trish.flv"

Thanks for Sharing the solution! :)

i have jwplayer embedded on my homepage in site root; i have videos in video folder, and images in images folder; when i set paths to these files - ../images/image.jpeg and ../videos/video.flv

the jpeg image file appears on the player, but when i press pay i get a video not found message.

any advice,

thanks.

@keith - Can you provide a link?

i'm only testing locally, i haven't uploaded yet. waiting 'til it all works.
but - player.swf is in root
videos are in /video folder
images are in /images folder

this is what i've got so far

<embed
src="../player.swf"
width="537"
type="application/x-shockwave-flash"
id="player2"
height="257"
name="player2"
allowscriptaccess="always"
allowfullscreen="true"
flashvars="file=../video/freebornjohn-englandsnewchains.flv&skin=../jwplayerskins/glow/glow.zip&icons=false&image=../images/freebornjohn.jpg&icons=false&controlbar=over" play="false" loop="false"/>

does this help?

keith

sorry,
further to last post;

the skin and image files work fine, it's only the video file that doesn't.

keith

@keith - Put up a test page, please. There is no other way to be able to tell what you are doing without this.

hi,
not sure how to go about uploading test page w/out breaking everything...

but, if you go here -- http://www.reddogonline.eu/reddogtunes.html

you'll see player functioning with reddogtunes.html in site root.

the problem occurs if i move reddogtunes.html into a sub-folder; links change from

for instance - playlistfile=playlists/tracks3.xml to playlistfile=../playlists/tracks3.xml

the ../ meaning 'go back to root, then into folder' i presume; this however breaks the player.

hope this explains the problem.
thanks for you patience with a willing but not very techy pupil!

keith.

Hi,
it's fixed for now. just a case of working out the various links.
some of the embed info references files direct, then the player.swf references other stuff.
i think i'm getting the hang of it......trial and error is an underrated sport.....

thanks for your help.

Keith

@keith - NP, Great! I am glad you got it working! :)

Hi! Why am i getting this error:Video not found or access denied on my link: http://www.mamboafrica.com/mambo2/

You are getting that error because the file does not exist.

http://www.mamboafrica.com/mambo2/modules/mod_simple_video_flash_player/images/stories/youtube_video...

404 Not Found

What happens when the link does exist?
And i still get the error.
I set permissions on video, and well, the whole jwplayer directory, i tried switching the video file to different directories, eg
letting it sit in .htdocs(root), moving it to the jwplayer folder etc..etc...

i now have it set so file namee ="/jwplayer/hide.flv/"

the video is downloadable

its NSFW though, so i dont want to post it here.

When i visit the link it does promp to download the file but, in the player it says access denied or file not found..

I have used JWplayer on many websites never ran into this problem

@Tommy -

Please put a non-NSFW video in the same location (presumably it would have the same problem) and post a link to that.

You know what, I just linked the file var to the full link ... eg

file=http://www.myvideo.com/video.flv&img=/images/blahblah.jpg

that fixed it and it really doesnt bother me, is there a way to hide file names in the source though?

@Tommy -

There's no way to hide the source URL, just like you can't hide the source URL for an image on a web page.

I have uploaded several films onto my server and they work fine but others recently are coming up with "video not found or access denied"

http://thelocalbusinessblueprint.com/about/module-7-social-media/

Thanks

@Robert -

You're getting that error message because the URLs you're setting are returning error pages. Visit this URL in your browser:

http://thelocalbusinessblueprint.com/wp-content/uploads/2011/02/module7.flv

Thanks, but how do I rectify this problem?

@Robert-

The most likely issue is that the file you're linking to does not reside on your web server. Double-check to make sure the file is in the correct location, and that you can browse to the URL without getting an error message.

Ok sure, I added the all the files the same way through filezilla, some are working ok and others are not.

is there any other reasons they would be showing the errors?

It could be that some of the file transfers failed without telling you. Try re-uploading the files that don't work.

module 7 was a bad example for you to look at beacuse it's am FLV file. If you look at module 8 that loads in the browser but not on the website
[11:25:06] Bradley Eynon: http://thelocalbusinessblueprint.com/wp-content/uploads/2011/01/module8.mp4

This is the link of that module 8 not opening on my site http://thelocalbusinessblueprint.com/about/module-4-email-marketing/

Here's the (working) link you posted:

http://thelocalbusinessblueprint.com/wp-content/uploads/2011/01/module8.mp4

Here's the (broken) link you're using on your page:

http://thelocalbusinessblueprint.com/wp-content/uploads/2011/02/module8.mp4

Note the difference between the two URLs.

Hello,

I am having a lot of trouble getting JWplayer to play on both iOS and PC/Mac for the same file (.m4v or .mp4 with H.264 / AAC).

We have one .mp4 that plays on both, but we are having trouble with additional videos and getting the "video not found or access denied" error when we attempt to play on PC/Mac. They work on iOS through the QuickTime player with no issue.

I need to get one of our new files playing on both iOS and on PC/Mac, but I'm not sure what the issue is. Going directly to the URL of the file, which is matched in the JWplayer embed code results in playback or download. The files are definitely there and the info is the same.

Could it be read/write issues on the files themselves? Do we need write access at all on these for JWplayer to function?

Server is Linux running Apache 2.2. Files are uploaded through our CMS. I cannot post links for business reasons, which I apologize for.

Thanks!

@brian -

Unfortunately, without an example demonstrating the problem you're having, there isn't much we can do to help diagnose the issue.

It's possible there's a permissions issue, but you wouldn't need write permissions on anything for the JW Player to be able to play them. As long as the files are accessible via the web (you can test in a web browser) the JW Player should be able to play them.

I get the "video not found or access denied" error... even when I try and play the default "readme.html" file. The files have been dropped on the server the way they were unpacked. I've tried it on two servers (W2003, IIS6) with the same result. I know the video file is there, so I'm assuming it's an access issue. But I can't figure it out!?! The non-functioning "readme" file can be viewed at http://www.brilliantbuildings.net/jwplayer/readme.html. Help!

@DrewW - Your video file is returning a 404 not found error - http://www.brilliantbuildings.net/jwplayer/video.mp4 , please check your paths.

Also, this is a forum for bug reports.

You should post in http://www.longtailvideo.com/support/forums/jw-player/setup-issues-and-embedding/

Still don't have the new JW Player? Get It Here